首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
拉钩
V2EX  ›  Linux

Ubuntu 18.04 以及其相关的衍生版 安装网易云音乐 1.0.0 版本时候 出现 libqt5libqgtk2 依赖问题解决方案

  •  
  •   zetaoyang · 159 天前 · 1124 次点击
    这是一个创建于 159 天前的主题,其中的信息可能已经有所发展或是发生改变。

    Ubuntu 18.04 以及其相关的衍生版(比如 Linux Mint 19) 在安装网易云音乐 1.0.0 版本时候出现 libqt5libqgtk2 依赖问题的解决方案:

    由于 libqt5libqgtk2 在 Ubuntu 18.04 的软件源中已经废弃,被 qt5-style-plugins 取代。 所以最好重新解包 netease-cloud-music_1.0.0-3_amd64.deb 修改 control 文件中的 libqt5libqgtk2 为 qt5-style-plugins。然后重新打包即可。

    具体步骤:

    mkdir -p extract/DEBIAN

    mkdir build

    dpkg-deb -x netease-cloud-music_1.0.0-3_amd64.deb extract/

    dpkg-deb -e netease-cloud-music_1.0.0-3_amd64.deb extract/DEBIAN

    dpkg-deb -b extract/ build/

    特此发一贴,希望对大家有帮助。

    PS. 由于 1.1.0 版本众所周知的问题,我还是继续使用 1.0.0 版本。

    附上 http://s1.music.126.net/download/pc/netease-cloud-music_1.0.0-2_amd64_ubuntu16.04.deb

    2 回复  |  直到 2018-07-10 08:58:29 +08:00
        1
    zeny620   158 天前 via Android
    就我遇到的 1.0.0 版本 拖拽有问题,1.1.0 切歌音量会最大,现在一直用网页版的
        2
    zetaoyang   158 天前 via Android
    @zeny620 我的拖拽没有问题,一直使用 1.0.0 版本
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   810 人在线   最高记录 4019   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 17ms · UTC 23:04 · PVG 07:04 · LAX 15:04 · JFK 18:04
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1