首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
V2EX  ›  Linux

如何解决 gcc-5-base 的依赖问题

  •  
  •   Mrkon · 10 天前 · 752 次点击
    为了安装 mysql 可视化工具 :mysql-workbench
    安装方式:
    1.sudo apt-get install mysql-workbench,出现了依赖问题 依赖: libgdal.so.1-1.11.3
    2.使用官网安装包 https://dev.mysql.com/downloads/workbench/
    sudo dpkg -i mysql-workbench-community-6.3.10-1ubuntu16.04-amd64.deb 同样出现依赖问题

    解决方法:
    1.
    使用命令 sudo apt-get update && sudo apt-get upgrade
    然后:sudo apt-get -f install
    不过结果是要我卸载 mysql-workbench (。。。无语)(失败)

    2.
    找到依赖源,问题出在同样的地方
    libgfortran3 : 依赖: gcc-5-base (= 5.3.1-14ubuntu2) 但是 5.4.0-6ubuntu1~16.04.9 正要被安装
    gcc 不能卸载(失败)

    3.
    使用 aptitude:sudo aptitude install mysql-workbench (失败)

    系统:Description: Ubuntu 16.04.3 LTS
    解决了一上午了,求解救
    15 回复  |  直到 2018-06-14 23:32:50 +08:00
        1
    defunct9   10 天前
    开 ssh
        2
    Mrkon   10 天前
    @defunct9 不太明白,能具体解释下吗?
        3
    batman2010   10 天前
    强行安装 deb 可能把依赖关系弄乱,可以试着先修复依赖(可能需要卸载 workbench),再用 apt 安装。
        4
    Mrkon   10 天前
    @batman2010 自动 fix 后在安装还是没有解决依赖问题,手动修复的方式该怎么做呢
        5
    sbw   10 天前
    你的 mysql-workbench 不要用网上下载的,用源里面的。
    看情况是你的系统已经落后了,检查一下更新通道。

    非常非常不推荐,很有可能 boom 的一个 hack 方法是改 /var/lib/dpkg/status 里的版本号或者直接解 deb 包运行。
        6
    batman2010   10 天前
    @Mrkon sudo apt-get update 和 sudo apt-get install -f 不报错就可以了,不用再手动修复。
    之后看看能不能把 libgdal 升级下版本吧。
        7
    artandlol   10 天前 via iPhone
    用 ansible-galery 自动安装 比 apt yum 好太多
        8
    msg7086   9 天前
    难道不是安装 libgdal-dev ?
        9
    Mrkon   9 天前
    @msg7086 所以依赖最后都指定到 gcc-5-base 版本不对
        10
    msg7086   9 天前
    @Mrkon
    libgfortran3 这个包,依赖同版本的 gcc base。
    有两个版本,5.3.1-14ubuntu2 和 5.4.0-6ubuntu1~16.04.9,你这边应该两者都装 5.4.0 版本。
    你可以用 apt-cache policy 看一下 libgfortran3 有没有正确指向 5.4 版本。
    如果指向正确,那么先 apt 安装这个包,看看前一个冲突发生在哪里,这样一级一级往前推。
        11
    Mrkon   9 天前
    @msg7086
    显示结果如下:
    libgfortran3:
    已安装:(无)
    候选:5.3.1-14ubuntu2
    版本列表:
    5.3.1-14ubuntu2 500
    500 http://mirrors.aliyun.com/ubuntu xenial/main amd64 Packages
    我该如何指向为 5.4.0-6ubuntu1~16.04.9。 求解
        12
    msg7086   9 天前
    软件源里看看有没有 security 项目。

    deb http://security.ubuntu.com/ubuntu xenial-security main
        13
    Mrkon   9 天前
    @msg7086 我在 /etc/apt/sources.list 中找到了如下:
    # deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
    是备注了的
        14
    defunct9   9 天前 via iPhone
    开 ssh,让我上去试试
        15
    msg7086   8 天前
    @Mrkon 解除封印后再试试?
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   鸣谢   ·   1793 人在线   最高记录 3541   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 20ms · UTC 14:06 · PVG 22:06 · LAX 07:06 · JFK 10:06
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1