首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
工单节点使用指南
• 请用平和的语言准确描述你所遇到的问题
• 厂商的技术支持和你一样也是有喜怒哀乐的普通人类,尊重是相互的
拉钩
V2EX  ›  全球工单系统

iOS8/ IE8 还有适配的必要吗

  •  
  •   FaiChou · 2017-12-07 14:22:56 +08:00 · 2346 次点击
    这是一个创建于 374 天前的主题,其中的信息可能已经有所发展或是发生改变。
    第 1 条附言  ·  2017-12-07 14:54:10 +08:00
    收集一些看法。集思广益。
    21 回复  |  直到 2017-12-08 09:50:58 +08:00
        1
    Reign   2017-12-07 14:25:37 +08:00
    我连 IE 和 Edge 都不要了,不值得,五年前我还在匹配 IE6.。。。
        2
    mokeyjay   2017-12-07 14:27:13 +08:00
    看你项目面向的群体啊……我现在开发直接无视 IE 全家
    但你要是为政府机关开发的话就必须考虑 IE
        3
    lll4m   2017-12-07 14:30:15 +08:00
    视需求文档而定吧,文档里没有就跟产品确认,让产品加上去
        4
    66beta   2017-12-07 14:39:56 +08:00
    看自己的访问统计啊,不要听别人乱 bb
        5
    lonelygo   2017-12-07 14:52:27 +08:00
    政府机关的话,还有大量的 XP。
        6
    janxin   2017-12-07 15:19:58 +08:00
    我们只适配现代浏览器
        7
    ionblue   2017-12-07 15:20:56 +08:00
    自己的一直是判断浏览器,不是火狐系或者 chrome 系,直接弹出窗口提示下载,其他全部拒绝,爱用用,不用滚。
    产品的话,就是要能照顾到就全部照顾到,甚至是为低版本 IE 重写页面,只要钱给够,波音 737-100 都能帮你弄一架回来。
        8
    duan602728596   2017-12-07 15:28:00 +08:00 via iPhone
    你是觉得给客户提示花一分钟下个新浏览器好?还是自己写一堆以后说不定留下一堆坑的费力还不一定讨好的兼容代码好?
        9
    ysc3839   2017-12-07 15:28:32 +08:00
    我个人认为 iOS 8 有必要,而且适配起来也不会算太难。但 IE 8 就没必要了,因为连 HTML 5 都不支持,IE 9 可能有必要,因为还是支持基本的 HTML5 特性的。
        10
    fulvaz   2017-12-07 15:32:40 +08:00
    @ysc3839 不要说 ios8, ios9 要不要支持都考虑一下, 见

    https://developer.apple.com/support/app-store/
        11
    walk1ng   2017-12-07 15:32:44 +08:00
    iOS8,最低要求了吧...
        12
    580a388da131   2017-12-07 15:36:52 +08:00
    计算下成本呗 不支持会赔钱的话就支持
        13
    jtsai   2017-12-07 15:44:26 +08:00 via Android
    看产品用户人群,假如你要做的是一个 JavaScript 开发者社区,那肯定不考虑 IE8。如果你的产品用户群是财务会计人群,我觉得 IE8 份额还特别大。最大都可能。
        14
    ysc3839   2017-12-07 16:01:58 +08:00
    @fulvaz 楼主指的是 iOS 8 的浏览器吧。
        15
    qumingkunnan   2017-12-07 16:03:51 +08:00 via Android
    考虑自己的使用群体才对,我还苦逼的要管 ie6,ie8 兼容性视图下正常使用,本来应该是前端的活儿😭
        16
    wxsm   2017-12-07 16:28:50 +08:00
    抛去场景讨论这个没有任何意义。
        17
    fulvaz   2017-12-07 17:08:40 +08:00
    @ysc3839 唔..还能 iOS10 用 iOS8 的浏览器不成?
        18
    ii4Rookie   2017-12-07 17:33:23 +08:00
    @lll4m 你看着我的刀再说一遍
        19
    yy910217   2017-12-07 17:54:03 +08:00
    领导在用 iOS8 你懂的
        20
    love2075904   2017-12-07 17:58:46 +08:00
    对不起,领导在用 IE8,领导就是可以为所欲为!
        21
    isbase   2017-12-08 09:50:58 +08:00
    要支持这些的除非钱比别人多几倍,否则别浪费生命了,大量新的东西需要学习呢
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3742 人在线   最高记录 4019   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 18ms · UTC 03:43 · PVG 11:43 · LAX 19:43 · JFK 22:43
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1