首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
华为云
V2EX  ›  Apache

apache 2.4.16 + PHP 5.5.29 使用 fcgi 方式跑 wordpress,想用.htaccess 限制 wp-login. PHP 是不是就不管用了?

  •  
  •   chinaglwo · 2017-09-21 16:12:24 +08:00 · 935 次点击
    这是一个创建于 422 天前的主题,其中的信息可能已经有所发展或是发生改变。

    apache 2.4.16 + PHP 5.5.29 使用 fcgi 方式跑 wordpress,想用.htaccess 限制 wp-login.php 是不是就不管用了?

    httpd.conf 里面的配置是 <VirtualHost :80> DocumentRoot /www/www/ ProxyPassMatch ^/(..php)$ fcgi://127.0.0.1:9000/www/www/$1 DirectoryIndex index.html index.php </virtualhost>

    比如在.htaccess 中写入 <Files "wp-login.php"> Require all denied </files>

    发现还是可以访问的,是不是因为 php 请求以及被转发到后端 fcgi 进程了? 那要怎么弄呢

    3 回复  |  直到 2017-09-22 09:30:45 +08:00
        1
    f2f2f   2017-09-21 16:36:43 +08:00
    WP Login Door
    试试这个插件
        2
    kuretru   2017-09-21 16:43:27 +08:00 via iPhone
    同问,需要限制 wp-uploads 目录下的 php 解析
        3
    chinaglwo   2017-09-22 09:30:45 +08:00
    顶啊。有没有高手指点
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   654 人在线   最高记录 3821   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.1 · 16ms · UTC 21:30 · PVG 05:30 · LAX 13:30 · JFK 16:30
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1